Linkerd hearbeat container error

I deployed Linkerd in an air-gapped environment and disabled heartbeat also in the yaml as “disableHeartBeat to true”. But when i check list of pods running in linkerd namespace, i can see linkerd-hearbeat pods still running with the status of ERROR. Is this normal?

I used this in both places.

linkerd install --crds --disable-hearbeat > crds_linkerd.yaml
Then apply that yaml

linkerd install --ha --disable-hearbeat >ha_linkerd.yaml
Then apply that yaml ( of course editing to replace the images / etc )

I had the same issue you did until I did it on the command line, when I manually edited the YAML file, the heartbeat nodes showed randomly after some time, but after the above methods poof they are gone.