Linkerd-proxy failed to become ready within 120s timeout

Today when i tried to deploy a same deployment running in another namespace into a new namespace to test something, the pods are not starting. I described the deployment and saw the error as “command ‘/usr/lib/linkerd/linkerd-await --timeout=2m --port=4191’ exited with 69: linkerd-proxy failed to become ready within 120s timeout”. I listed the PODs in linkerd namespace and found the PODs running as below and no abnormality found:

linkerd-destination-7f8bc8c4b7-m4bcg 4/4 Running 0 11h
linkerd-identity-55d6f97487-227ff 2/2 Running 0 11d
linkerd-proxy-injector-7779cf6448-dj9w9 2/2 Running 0 11d

No change to my environment and suddenly this error is occurring and making the deployments to fail.

Any leads on the fixing the issue??

Did you manage to fix this?
It started happening to us yesterday and currently he only remedy is to upgrade to the latest version.
We tried restarting pretty much everything in the cluster related or unrelated and nothing resolves the issue.