Linkerd2 Tap Error with MissingEndPoints

I installed stable version 2.13.5 and getting the below error when i tried to list any resource in the cluster:

E0808 20:44:02.037651 29116 memcache.go:255] couldn’t get resource list for the server is currently unable to handle the request

Tried to uninstall both viz and linkerd and install back. Still getting the same error. The kubectl get apiservices shows the endpoint not available for tap as below:

NAME SERVICE AVAILABLE AGE linkerd-viz/tap False (MissingEndpoints) 96m

When i check the components in linkerd namespace, all are running fine

pod/linkerd-destination-6d74757775-tg5kz 4/4 Running 0 10h
pod/linkerd-identity-76b48f7b7d-lbr55 2/2 Running 0 10h
pod/linkerd-proxy-injector-89989894d-klmr2 2/2 Running 0 10h

But for the component in linkerd-viz namespace, the tap components are not running:

pod/metrics-api-6c949cc5d6-m8xp7 2/2 Running 0 4h7m
pod/prometheus-67759d7cf9-bbnzq 0/2 Pending 0 4h7m
pod/tap-5867ddcff6-n7nkc 0/2 Pending 0 3h12m
pod/tap-67664486fb-6nn9z 0/2 Pending 0 151m
pod/tap-injector-6dddc6956c-g6zk4 0/2 Pending 0 4h7m
pod/web-7d46789588-558qz 0/2 Pending 0 4h7m

Is this a configuration or permission issue?

Hi @Kuppusamy

Is this the same issue as couldn't get resource list for `` · linkerd/linkerd2 · Discussion #11213 · GitHub ? I believe that was caused by a version mismatch between the kubectl and kubernetes server versions. I would recommend making sure your kubectl and kubernetes server versions match.

Thanks…this helped to resolve the issue.