Linkerd-Viz and Grafana

Hi All,

I have linkerd, linkerd-viz and grafan installed into my cluster, all installed via helm. Have followed the documentation in Grafana | Linkerd. Clicking on the grafana icon in the linkerd viz dashboard, and the grafana dashboard comes up, there is no data displayed. Looking at the grafana logs I see 403 errors, so assume this is a permissions issue.

logger=context userId=0 orgId=1 uname= t=2023-07-19T10:21:15.804806884Z level=info msg="Request Completed" method=GET path=/api/datasources/uid/P1809F7CD0C75ACF3/resources/api/v1/series status=403 remote_addr= time_ms=8 duration=8.351472ms size=0 referer="http://localhost:50750/grafana/d/linkerd-namespace/linkerd-namespace?orgId=1&refresh=1m&var-namespace=emojivoto" handler=/api/datasources/uid/:uid/resources/*

I’ve tried moving the grafana install into the same namespace as linkerd-viz. I’ve also tried various settings on the datasource in grafana

        apiVersion: 1
        - name: prometheus
          type: prometheus
          access: proxy
          orgId: 1
          url: http://prometheus.linkerd-viz:9090
          isDefault: true
          basicAuth: false
          withCredentials: false
            timeInterval: "5s"
            tlsSkipVerify: true
          editable: true

Any help appreciated.


Resolved with this Grafana cannot connect to Prometheus from Linkerd Viz · Issue #10891 · linkerd/linkerd2 · GitHub