How to configure linkerd viz to use external grafana within the same cluster?


I have successfully deployed Linkerd2, Bitnami Grafana Operator, Bitnami Kube Prometheus, Bitnami Thanos, and Linkerd Viz to our k8s cluster. Viz was deployed to use my Grafana Operator and Kube Prometheus instances.

My final task is getting the Grafana gravatars in Viz to open their Grafana dashboards using my Grafana Instance.

I know that Linkerd2’s dashboards need to be put someplace so our Grafana Instance can load them, and that I must configure Grafana’s reverse proxy. However, when I changed the root_uri for my Grafana Operator to the documented value in “In-cluster Grafana instances” and redeployed, it didn’t work.

I couldn’t find any specific information about how to load Linkerd2’s dashboards into our Grafana Operator instance. I manually imported them, and could seem Linkerd2’s metrics when clicking on a dashboard within Grafana Operator. However, when I clicked a Grafana gravatar in Viz, it didn’t work. I suspect that Viz must use the dashboards that would be installed if I used Viz’s Grafana.

Can someone please provide specific instructions for resolving this issue? I am sure that the Bitnami stack that I am using is popular and this posting could help others. Thanks for your time and interest!

Our cluster has linkerd2 deployed and injection to all pods in a set of namespaces is working.
I have deployed Bitnami’s Grafana Operator, Kube Prometheus, and Thanos to our k8s cluster. They are all working properly. Grafana Operator has been added to Linkerd2’s mesh, but Kube Prometheus and Thanos are not meshed.

I installed linkerd viz, with the following command:

linkerd viz install --set prometheusUrl="http://prometheus-kube-prometheus-prometheus.monitoring.svc.cluster.local:9090",prometheus.enabled=false,grafana.url="http://grafana-grafana-operator-grafana-service.monitoring.svc.cluster.local:3000" | kubectl apply -f -

After launching Viz, I see metrics and Grafana avatars.

Grafana dashboard available at:
Opening Linkerd dashboard in the default browser

When I click on a Grafana avatar, the browser opens to:


and the content reports “This page isn’t working — HTTP Error 502”.

Please disregard this posting. I could not locate a link to delete it.

@abitofhelp I can delete it, if you’re good with that. Just let me know.