Opaque ports configuration unclear?

Hi all! I’m using Linkerd for my project and I already have it set up with my web, api, and mongodb pods. In this PR I’m adding NATS → Adding NATS + Jetstream by joswayski · Pull Request #980 · plutomi/plutomi · GitHub

And ran into some issue when adding port 4222 to the opaque ports list.
I have added the opaque port annotation to NATS by itself, the nats-box by itself, and both at the same time but I cannot connect from one to the other.
Attaching a link because I cannot upload an image, will try in one of the replies: https://share.cleanshot.com/2D0p3LY9

If I remove Linkerd, this connection works and the message is published without issue. Am I doing something wrong here? Any help is appreciated!

Hi all, I’m an idiot. I was setting the annotation in the wrong place (everywhere BUT the statefulSet.spec.template.metadata.annotations).

1 Like

Glad you figured it out!