Helm install with linkerd-cni plugin get error on init container linkerd-network-validator PodInitializing

we are running on OCI cluster
the OS of the nodes are:
Shape: VM.Standard.E4.Flex
Red Hat Enterprise Linux release 8.9 (Ootpa)

helm install get error adding pod linkerd_linkerd-proxy-injector-58cc9dc565-k69px to CNI network “oci”: plugin type=“oci-ipvlan” failed (add): unable to allocate IP address

I install the linkerd-cni with helm using flux

but the control-plane init container which I used the helm release (we are using flux) is not initializing:

I set the repairController to true and the linkerd-cni pods are running with 2 containers .

I tried the iptablesMode: “nft” but with no success
I tried to comment the: proxyUID: 2102 but still with no success

Defaulted container “linkerd-proxy” out of: linkerd-proxy, proxy-injector, linkerd-network-validator (init)
Error from server (BadRequest): container “linkerd-proxy” in pod “linkerd-proxy-injector-854f664bc5-vk42q” is waiting to start: PodInitializing

Hi @yaronkalatian

I’ve never seen this particular error before, but based on the message in the error, it does seem like it might be an issue with the oci-ipvlan plugin, not the linkerd-cni plugin.