# Problem pulling pod images in ARGO+EKS

**URL:** <https://linkerd.buoyant.io/t/problem-pulling-pod-images-in-argo-eks/582>\
**Category:** Linkerd General Discussion\
**Created:** [August 30, 2024, 9:18pm UTC](https://linkerd.buoyant.io/t/problem-pulling-pod-images-in-argo-eks/582 "2024-08-30T21:18:16Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![amartin](https://avatars.discourse-cdn.com/v4/letter/a/7993a0/32.png) [@amartin](https://linkerd.buoyant.io/u/amartin)\
**Post date:** [August 30, 2024, 9:18pm UTC](https://linkerd.buoyant.io/t/problem-pulling-pod-images-in-argo-eks/582/1 "2024-08-30T21:18:16Z")

</div>

Following this guide:  
linkerd(.)io/2-edge/tasks/gitops/  
I deployed linkerd through GitOps to my EKS cluster, everything deployed succesffuly except for the destination, identity, injector heartbeat, etc pods for the following reason:  
Failed to pull image “cr.l5d(.)io/linkerd/proxy:linkerdVersionValue”: rpc error: code = NotFound desc = failed to pull and unpack image “cr.l5d(.)io/linkerd/proxy:linkerdVersionValue”: failed to resolve reference “[cr.l5d.io/linkerd/proxy:linkerdVersionValue](http://cr.l5d.io/linkerd/proxy:linkerdVersionValue)”: cr.l5d(.)io/linkerd/proxy:linkerdVersionValue: not found  
I’m running EKS 1.30, all of my nodes are healthy, i do not have any firewalls rules blocking anything. This is where i’m pulling from - [https://github/linkerd/linkerd2.git](https://github/linkerd/linkerd2.git)  
Not sure what else to do.  
(had to change some of the links with (.) new user so i can only have 2 links)

---

<div class="post-metadata">

**Author:** ![Mahendran](https://yyz1.discourse-cdn.com/flex029/user_avatar/linkerd.buoyant.io/mahendran/32/217_2.png) [@Mahendran](https://linkerd.buoyant.io/u/Mahendran)\
**Post date:** [January 9, 2025, 9:45pm UTC](https://linkerd.buoyant.io/t/problem-pulling-pod-images-in-argo-eks/582/2 "2025-01-09T21:45:23Z")

</div>

The issue is that `linkerdVersionValue` wasn’t replaced with the actual Linkerd version. Update your config to use a valid version like `stable-2.14.1` for the proxy image and redeploy
